Archived OpenModelica forums. Posting is disabled.

Alternative forums include GitHub discussions or StackOverflow (make sure to read the Stack Overflow rules; you need to have well-formed questions)

Forgot password? | Forgot username? | Register
  • Index
  • » Users
  • » Dols
  • » Profile




I have a question about the interval settings considering a simulation in OMedit.
I have two models with a slight difference that I want to compare, therefore I have one variable in the model but all my other settings are identical.

To properly compare my models I want the measuring time points to be the same in each model. Therefore I put my time and interval in both models the same, furthermore I am using the dassl solver.

Though I have the problem of not having the same measuring output time points. I have tried to change the solver but I kept experiencing the same problem. 

Could someone tell me why I have this problem and if there is a way to get arround it?


Yes that is what I mean, thank you!


I am working in OMedit, and want to have my output in a table instead of a graph. Is this possible?
I could not find it online, though I am also pretty new in the enviroment so I might have looked over it.

I am trying to intergrate the ScrollWaterToWater heatpump component in my model from the Buildings v8.0.1. lib.(Buildings=>Fluid=>Heatpumps=>ScrollWaterToWater)

To get an understanding of its usage I first tried duplicating the ScrollWaterToWater_OneRoomRadiator example, where this component is being used. Though when duplicating this model into my own package it seems to copy everything except the ScrollWatertoWater heatpump, thus I added that later identical to the example.

  ScrollWaterToWater heaPum(
    redeclare package Medium1 = MediumW,
    redeclare package Medium2 = MediumW,
    redeclare package ref = Buildings.Media.Refrigerants.R410A,
    "Heat pump"

This give me the following error:
Function Data.ScrollWaterToWater.Heating.Daikin_WRA072_24kW_4_30COP_R410A not found in scope model.

I thought this might be the case because the package is located in the buildings lib and not in my own package. Therefore I added the files to my package and reverenced them again in this new location. Though I now get the error that I have more variables than equations.

How should I properly add the data to the Heatpump? And why do I get the first error?

Hi everyone,

I am trying to run one of the Thermal Zone=>EnergyPlus=> SingleFamilyHouse examples from the Buildings v. 8.1.0 extended library in the OMedit enviroment. Although the simulation does seem to run it does not give any outputs. Does anyone know if I can take steps to resolve this problem?
The examples outside the EnergyPlus pocket do run correctly.

Yes I am indeed using OMEdit, when I go to tools I find a overview at libraries, for what is MSL an abbriviation? I cant find it there.

I just started working with OpenModelica, I want to use the IDEAS and buildings library. Though when downloading the Openmodelica software it doesnt seem to be compatible because it is not the correct version. Though when downloading it it does seem to also include the package 3.2.3, does someone know if there is something I need to select or download? I cant seem to find it online.

[3] 10:10:13 Scripting Warning
IDEAS requested package Modelica of version 3.2.3. Modelica 4.0.0 is used instead which states that it is only compatible with a conversion script. OpenModelica currently does not support conversion scripts and will proceed with potential issues as a result.

  • Index
  • » Users
  • » Dols
  • » Profile
You are here: