Archived OpenModelica forums. Posting is disabled.

Alternative forums include GitHub discussions or StackOverflow (make sure to read the Stack Overflow rules; you need to have well-formed questions)

Forgot password? | Forgot username? | Register
  • Index
  • » Users
  • » Ueda
  • » Profile



Dec-01-20 23:22:01
I would like to translate OpenModelica User's guide into Japanese.

Thank you for your introduction.
I'm interested in transition OMEdit.
I have never used Qt, so let's check the translation flow first.

Dec-01-20 12:46:38
I would like to translate OpenModelica User's guide into Japanese.

Thank you very much for permission to translate and thank for answering the email.

I would like to publish it using CC BY 4.
I hope this will help to progress of Modelica in any way.


Nov-30-20 15:39:32
I would like to translate OpenModelica User's guide into Japanese.


My name is Ueda.
I'm member of the Open CAE Society of Japan that is promoting the spread of CAE on open source.
I would like to ask if there is any problem to translate the OpenModelica User's Guide into Japanese.

I also use OpenModelica and I apricate you for developing great software.
As part of academic activities, I would like to translate to Japanese the OpenModelica User's Guide and release it for free under GPL v3 license.

Is there anything I should be aware of when it comes to translation?

I read User's Guide license and there will be no problem with translation activities.
I sent Open Source Modelica Consortium similar mail at May, but I can't find reply mail yet.
Therefore I would like to take this forum to ask a question.
I will cancel the question immediately if it is inappropriate.

Jan-19-18 04:29:24
can't save mmodel if with any errors


OpenModelica can't save the model with errors.

So if you want to save the model, How about you do comment out the error row?

Or how about saving the code to other text file.


I'm in following trouble.

Right click on the icon which is Diagram view, another icon is selected.

In OM 1.12, double-clicking on the icon opens a different icon parameter window

When OM 1.11 is set, the above problem disappears but when right clicking on an icon, another icon is selected.

· Even if I click on any icon, the last drag & dropped icon will be selected

· Similar phenomenon does not occur in other personal computers

Could anyone tell me how to solve this problem?


I'm tring to use external C function with array.
I'm testing very simple code for passing and returing the array.
but  I got a error message when I simulated the .mo file.

Followings are my .mo , .c and .h files.
(attached files)


.mo file

model External_Array
/*This code is very simple code for testing external c function with array*/
  function FuncArray               
    input Real[:] a;               
    output Real[2] b;   
    external b=ExternalC_array(a,2) annotation(Library="functionC.o",Include = "#include \"ExternalC.h\"");               
  end FuncArray;
    Real[2] x={1,2};               
    Real[2] y;               
    y = FuncArray(x);       
end External_Array;

.c file
/* ExternalC.c */
double ExternalC_array(double *x, int n)
    int i;
    for(i = 0; i < n; i++){
        x[i] = x[i] / 2;
    return x, n;

.h file
/* ExternalC.h */
double ExternalC_array(const double*, int);

And following is the error message.


[D:/.../] Error: The lhs (result) of the external function declaration has array type (Real[2]), but this is not allowed in the specification. You need to pass it as an input to the function (preferably also with a size()-expression to avoid out-of-bounds errors in the external call).

[D:/.../] Error: Class FuncArray not found in scope External_Array (looking for a function or record).
Error: Error occurred while flattening model External_Array

I know that I'm write wrong argument in .c file.

external b=ExternalC_array(a,2) annotation(Library="functionC.o",Include = "#include \"ExternalC.h\"");

but I don't know hot to fix it.

(1)  Plase teach me how to fix the avobe code?
(2)  Please let me know if you know a good example which contains .mo , .c code.

You are welcome Nasrou.

Maybe for loop can not be used.
Beause there is no loop command in this list … pting.html

If you want to make many similar commands,
you have to make another program by another language.

If you find how to use for loop,
please teach me.

Add to
I will fix the above reply.
I found for loop example from your forum. … eter-sweep
Good luck


Do you want to create script file that execute a simulation?
If so you can read here
OMShell and OMNotebook introduction and exercises

And I write down small overview.

Simulation execution script is written by some text editor and save as .mos file.
Code example is following


cd("directory address);
loadFile("File name");
simulate(model name,startTime=0,stopTime=1 ...  );

Go to the directory of .mos file using cd() command in OMSell.



runScript("mos file")

Then the script start.

If you want to control parameter value according to a result, I don't know how to creat.


Apr-27-17 06:41:15
Category: Developer


I tried to build OMCompiler on Windows7.

I got following error.

*Error message was japanese, so I translated it into English.
I'm sorry If this is not an appropriate translation.

$make -f Makefile.omdev.mingw -j8 2>&1 | tee make.log
config.status: executing default commands
make[1]: leaving directory '/c/OpenModelica/OpenModelica/OMCompiler'
Makefile.omdev.mingw:37: recipe for target `omc' failed
make: *** [omc] error 2

Plase advice me how to fix the error.


Maybe I think you need another command.
I am sorry if I made a mistake, please try the following command in MSYS for proxy setting.


git config --global http.proxy proxy.server.address:8080

   git config --global https.proxy proxy.server.address:8080



I tried to compile OMC on Windows7 with reference to the following URL.
Compiling OMC using OMDev package

When I tried to do "•Editing the OMDev-MINGW-OpenModelicaBuilder " that is in "Compiling OMC using Eclipse", I haven't found "OMDev-MINGW-OpenModelicaBuilder" in Builders of "Properties for OpenModelica".
Attached picture is my "Properties for OpenModelica" window.

I think It may cause by path of "OMDev-MINGW-OpenModelicaBuilder32bit.launch" or "OMDev-MINGW-OpenModelicaBuilder64bit.launch" files.
But I don't know how to set the proper path.

Please tell me how to fix this problem?

OMDev path of my PC is C:\OMDev.
OpenModelica path of my PC is C:\OMDev\OpenModelica.

Apr-13-17 08:13:22
Category: Programming


I tried options  for the model in OMShell.



And following is Result.

matching and sorting (n=18156)270.313.7
analyzeInitialSystem (initialization)164.18.3
prepare postOptimizeDAE:271.413.8
postOpt tearingSystem (initialization)317.716.1
postOpt removeSimpleEquations (simulation)270.513.7
postOpt tearingSystem (simulation)315.116.0
ostOpt detectJacobianSparsePattern (simulation)268.813.6

I got about 100sec reduction about analyzeInitialSystem, but it's not enough.

I would like to send a mail for

Also, if you know how to try Simplify2 could you tell me it please.

Thanks for your help.

Apr-12-17 04:32:23
Category: Programming

Thanks you

I tried to -d=execstat for the model.
And then following is result of high percentage commands.

matching and sorting (n=18156)271.413.1
analyzeInitialSystem (initialization)252.912.2
prepare postOptimizeDAE:271.413.1
postOpt tearingSystem (initialization)318.715.4
postOpt removeSimpleEquations (simulation)271.013.1
postOpt tearingSystem (simulation)317.115.3
ostOpt detectJacobianSparsePattern (simulation)269.013.0

*The model doesn't have pre() and is nonliear equation.

I want to study to reduce these time.
But, If someone know how to speedup these performance
could you tell me it, please?

Apr-11-17 08:39:31
Category: Programming


I made a model to solve the stress distribution that represented by a two dimensional array.

timeBackend of the model that has 40*70 array took about 20-30 minutes.
It'a too late for me...

I found following some tickets.

I applied --removeSimpleEquations=new which is writen in the #3695 but it was same timeBackend.
And I would to try to compile simplify2 but I didn't know how to compile it.

Do someone know how to speedup the timeBackend?

Version : OM 1.11.0(OM 1.12Dev is same timeBackend)
OS        :  Windows7
CPU      :  Core i7-4810MQ 2.8GHz
memory : 32Gbyte

Following are mistake.
Version : OM 1.9.6(OM 1.12Dev is same timeBackend)
OS        :  Windows7
CPU      :  Core i5-6300U 2.4GHz
memory : 12Gbyte

  • Index
  • » Users
  • » Ueda
  • » Profile
You are here: