Archived OpenModelica forums. Posting is disabled.

Alternative forums include GitHub discussions or StackOverflow (make sure to read the Stack Overflow rules; you need to have well-formed questions)

Forgot password? | Forgot username? | Register

OM installation on Ubantu

OM installation on Ubantu

Hi all,

I got a problem when I try to install OM on a Linux platform. When I tryed the code

sudo apt-get install openmodelica

There is always errors Failed to fetch … _amd64.deb  Undetermined Error [IP: 80]

Then it will failed the next step when I run code sudo apt-get install omlib-.*
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
omlib-aixlib-0.7.3 : Depends: omlib-modelica-devicedrivers-1.5.0 but it is not installable
omlib-arduino-0.1.0 : Depends: omlib-modelica-devicedrivers-1.5.0 but it is not installable
E: Unable to correct problems, you have held broken packages.

Anyone can help me with that?

Thanks in advance

Re: OM installation on Ubantu

I haven't used Ubuntu for years however...
Probably a step further could be download the *.deb package (with wget or with a browser) and try to install it with "dpkg -i"
This will works if the package works and the dependencies are all met.

From the output it seems that the problem may be with the repositories.
If you are brave enough and know what you're doing you could select a different repository form the configuration file of apt-get in /etc folder

Edited by: ElMastro - Jul-03-19 15:59:23

Re: OM installation on Ubantu


Thank you for your reply. It seems like a connection problem because I tried again to download these packages and it worked.

There are 0 guests and 0 other users also viewing this topic