Archived OpenModelica forums. Posting is disabled.

Alternative forums include GitHub discussions or StackOverflow (make sure to read the Stack Overflow rules; you need to have well-formed questions)

Forgot password? | Forgot username? | Register
  • Index
  • » Users
  • » Jarry
  • » Profile



Now I have different error message:


W: Conflicting distribution: ulyana Release (expected ulyana but got focal)

I'm trying to install OM on linux, but I get this  error when updating repository:


sudo apt update

Ign:16 ulyana InRelease                     
Err:17 ulyana Release                       
  404  Not Found [IP: 80]
Reading package lists... Done                                                 
E: The repository ' ulyana Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Trying later to install openmodelica shows only message:


sudo apt install openmodelica

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package openmodelica

How can I fix it?

I'm still quite new to OpenModelica, but I have been using other Modelica-based software for years and one thing I'm missing terribly in OMEdit is ability to open multiple plots (tabs in "plotting perspective") or to split single plotting tab into multiple sub-plots (i.e. horizontally in the midle, into upper and lower plot)...

When I'm in "modeling perspective", every new model/function I double-click opens in new tab. How can I do the same in "plotting perspective", i.e. plotting two variables, each in its own diagram?

OK, I found how to open "new plot window" when I switched "plot toolbar" on. Strangely, I did not find menu-entry for this, only icon...

As local admin I installed OpenModelica 1.11.0-64b on a few computers (with Windows7/64b) for students. I tried to start it and everything seemed to be ok. But to my big surprise, those other local users can not use it!

First of all, they have no start menu entry. Only the user who installed it (me) had entry in "C:\Users\Me\StartMenu\Programs". So I quickly made copy of those entries for all users.

But even then it did not work! When those other users tried to start OMedit, all they got is error-message "Could not find environment variable OPENMODELICAHOME. Please make sure OpenModelica is installed properly".

Now I do not understand this. What does it mean "installed properly"? I installed it as admin, and expected all other local users can use it as well. And I'm pretty sure it worked like this some time back in 1.5-version. So why is it that now OpenModelica can not be used in multi-user environment on Windows???

I tried it with 1.12.0-dev.alpha1-64b, the same: administrator, who installed OpenModelica, can use it. But other local users can not. What is this? Bug of feature? Am I doing something wrong?

OK, now I understand. I was confused with that "data manipulation".

BTW, would not be easier to have simply all fields active? I mean, so that user could edit all parameters:


Then depending on the first parameter "tableOnFile" value (false/true) either "table" would be considered (for numerical input) or "tableName" and "fileName" (for file-input).

Not sure if we understand each other, but I do not want any interactive data manipulation (they are in my case stored in mat-file, and I do not want to touch them). All I want is to change two text-parameters ("tableName" and "fileName") the same way, as I changed "tableOnFile" from "false" to "true". But this is not possible in diagram-view.

I switched to text-view and could edit it:
Modelica.Blocks.Tables.CombiTable2D combitable2d1(tableOnFile = true, tableName = "mytable", fileName = "D:/myfiles/data.mat")

This change is then reflected back in diagram-view (those two parameters have then new values) but still I can not change these two parameters there. Only in text-view...

This is probably very stupid, but... despite of had been using Dymola for a few years, I trully do not know how to use CombiTable2D in OMEdit (OpenModelica) to read data from matlab-file.

When I right-click on the component, I see a few parameters. I changed "tableOnFile" from default "false" to "true" (because next to it there is "= true, if table is defined on file or in function usertab"). But what now? I can not edit fields "tableName" or "fileName", they are greyed out with "NoName" values. In "table" field there is "fill(0.0, 0, 2)". I tried to remove this, but when I re-opened component properties again, it was there again.

IIRC, in Dymola all I had to do was right-click on the field, and then select mat-file. How am I suppose to do it in OMEdit/OpenModelica?

  • Index
  • » Users
  • » Jarry
  • » Profile
You are here: