OpenModelica


Forgot password? | Forgot username? | Register

Can't make development environment

Can't make development environment

I'm making OpenModelica developmnet environment to learn OpenModelica.
But I couldn't make it. Please let me know how to make it.

---------------
I checked-out and dowloaded
   - OMDev
   - OpenModelica
   - Eclipse 3.5

I saved these folders
   - C:\om\OMDev
   - C:\om\Eclipse3.5
   - C:\om\workspace\OpenModelica
and I installed the modelica plugin to Eclipse.

I set OMDev environment variable.
     OMDev = C:\om\OMDev

I installed jdk1.8 to
   - C:\Program Files (x86)\Java\jdk1.8.0_172

I executed
   - C:\om\OMDev\SETUP_OMDEV.bat
   - C:\om\OMDev\SETUP_OMDEV_Qt5.bat

I checked below batch command correctly
   - C:\om\OMDev\tools\msys\mingw32_shell.bat
   - C:\om\OMDev\tools\msys\mingw64_shell.bat

I copied OpenModelica project file and builder file.
   C:\om\workspace\OpenModelica\
       .project-sample -> .project
   C:\om\workspace\OpenModelica\.externalToolBuilders
       OMDev-MINGW-OpenModelicaBuilder.launch-sample -> OMDev-MINGW-OpenModelicaBuilder.launch

I launched Eclipse and set workspace to C:\om\workspace\.
I created "OpenModelica" project.

On Eclipse project setting,
I add jdk-path to PATH
    PATH = C:\Program Files (x86)\Java\jdk1.8.0_172\bin;.......

I changed make.exe path
   [before]${env_var:OMDEV}\tools\msys\bin\make.exe
   [after]${env_var:OMDEV}\tools\msys\usr\bin\make.exe

I rebuild OpenModelica project, but I got any errors.

[Errors]
/bin/sh: svn: command not found
/bin/sh: svn: command not found
Current revision:
Could not retrieve revision number. revision.h not updated
Building OMC using OMDev with the following settings...
Using OMDev: /c/OMDev/
Using Files: mo
Using Path : /c/Program Files (x86)/Java/jdk1.8.0_172/bin:/c/om/OMDev/tools/mingw/bin:/bin:/c/om/OMDev/tools/rml/bin/:/local/bin:/c/om/OMDev/bin/mico/current/hmmc/windows:/c/windows/system32
which gcc
which: no gcc in (/c/Program Files (x86)/Java/jdk1.8.0_172/bin:/c/om/OMDev/tools/mingw/bin:/bin:/c/om/OMDev/tools/rml/bin/:/local/bin:/c/om/OMDev/bin/mico/current/hmmc/windows:/c/windows/system32)
make: *** [settings] Error 1
Makefile.omdev.mingw:86: recipe for target 'settings' failed


I think my builder-setting has any wrongs.

---------------------------------
My builder-setting
---------------------------------
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<launchConfiguration type="org.eclipse.ui.externaltools.ProgramBuilderLaunchConfigurationType">
<stringAttribute key="org.eclipse.debug.core.ATTR_REFRESH_SCOPE" value="${workspace}"/>
<booleanAttribute key="org.eclipse.debug.core.appendEnvironmentVariables" value="false"/>
<mapAttribute key="org.eclipse.debug.core.environmentVariables">
<mapEntry key="PATH" value="C:\Program Files (x86)\Java\jdk1.8.0_172\bin;${env_var:OMDEV}/tools/mingw/bin;${env_var:OMDEV}/tools/msys/bin;${env_var:OMDEV}/tools/rml/bin/;${env_var:OMDEV}/tools/msys/local/bin;${env_var:OMDEV}/bin/mico/;c:/windows;c:/windows/system32;"/>
<mapEntry key="SystemDrive" value="${env_var:SystemDrive}"/>
<mapEntry key="SystemRoot" value="${env_var:SystemRoot}"/>
<mapEntry key="TEMP" value="${env_var:TEMP}"/>
<mapEntry key="OMC_BUILD_STATIC" value="/static"/>
<mapEntry key="OMC_BUILD_FROM" value="mo"/>
<mapEntry key="TMP" value="${env_var:TMP}"/>
<mapEntry key="OPENMODELICALIBRARY" value="${project_loc}\build\lib\omlibrary\"/>
<mapEntry key="COMSPEC" value="${env_var:COMSPEC}"/>
<mapEntry key="OMDEV" value="/c/OMDev/"/>
<mapEntry key="CLASSPATH" value="${env_var:OMDEV}/bin/antlr/antlr.jar"/>
<mapEntry key="OPENMODELICAHOME" value="${project_loc}/build"/>
</mapAttribute>
<booleanAttribute key="org.eclipse.debug.ui.ATTR_LAUNCH_IN_BACKGROUND" value="false"/>
<booleanAttribute key="org.eclipse.ui.externaltools.ATTR_BUILDER_ENABLED" value="true"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LOCATION" value="${env_var:OMDEV}\tools\msys\usr\bin\make.exe"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_RUN_BUILD_KINDS" value="full,incremental,"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_TOOL_ARGUMENTS" value="-f Makefile.omdev.mingw ${string_prompt}"/>
<booleanAttribute key="org.eclipse.ui.externaltools.ATTR_TRIGGERS_CONFIGURED" value="true"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_WORKING_DIRECTORY" value="${project_loc}"/>
</launchConfiguration>

Edited by: S.Nak - Jun-10-18 12:53:35
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests and 0 other users also viewing this topic
You are here: