OpenModelica


Forgot password? | Forgot username? | Register

OpenModelica not installed for all users

OpenModelica not installed for all users

As local admin I installed OpenModelica 1.11.0-64b on a few computers (with Windows7/64b) for students. I tried to start it and everything seemed to be ok. But to my big surprise, those other local users can not use it!

First of all, they have no start menu entry. Only the user who installed it (me) had entry in "C:\Users\Me\StartMenu\Programs". So I quickly made copy of those entries for all users.

But even then it did not work! When those other users tried to start OMedit, all they got is error-message "Could not find environment variable OPENMODELICAHOME. Please make sure OpenModelica is installed properly".

Now I do not understand this. What does it mean "installed properly"? I installed it as admin, and expected all other local users can use it as well. And I'm pretty sure it worked like this some time back in 1.5-version. So why is it that now OpenModelica can not be used in multi-user environment on Windows???

I tried it with 1.12.0-dev.alpha1-64b, the same: administrator, who installed OpenModelica, can use it. But other local users can not. What is this? Bug of feature? Am I doing something wrong?

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

Hi,

I also just got hit by this problem. I believe the relevant issue on bug tracker is ticket 3554#. Unfortunately it doesn't provide solutions.

best, Pierre

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

So is there no update or fix to this problem, which is exactly as mine?

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

There is a file "InstallMode.txt" in the installation directory.
What are the contents of it? Is it "AllUsers" or "CurrentUser"?

Adeel.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

Sorry but what install directory?  I downloaded the Windows 64bit .exe file and the .md5sum file and put them together in a folder.  I then ran the .exe file and it installed OM but only for me the engineering lab administrator, no other users can see it.

Thanks

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

The installation directory where you installed OpenModelica.

Adeel.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

It says CurrentUser
C:\Program Files\OpenModelica1.14.1-64bit

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

For you as an engineering lab administrator, you can run the installer in the silent mode to be installed for all users.

Start the installer from command line with /S switch.

Adeel.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica not installed for all users

Hey adeas
Ok that worked.  Thanks

Edited by: chemtec - Jan-22-20 19:00:03
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests and 0 other users also viewing this topic
You are here: