OpenModelica


Forgot password? | Forgot username? | Register

OpenModelica incompatible with Sundials 3?

OpenModelica incompatible with Sundials 3?

Hi,

I'm trying to build OMC with cpp runtime flag in Fedora 29.  The Sundials version in the dnf repo is 3.1.1.  Looks like they changed the sundials_config.h definitions for build version (BUILD_PACKAGE_VERSION no longer exists).

Also sundials changed up the cvode solvers, and cvode/cvode_spgmr.h no longer exists (now sunlinsol/sunlinsol_spgmr.h ... looks like a lot of solvers were redefined).

I didn't know if this was already reported, and was curious if these new libraries were planning to be supported.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: OpenModelica incompatible with Sundials 3?

A complete copy of Sundials is included in OpenModelica; the OS-provided version should not be used. If it somehow is used, please provide a pull request fixing linking order.

Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests and 0 other users also viewing this topic
You are here: