OpenModelica


Forgot password? | Forgot username? | Register

GUI : unable to use . when configurating the simulation

GUI : unable to use . when configurating the simulation

With the latest version of OpenModelica (OMEdit v1.11.0 64-bit),
we are not able to define some parameters of the simulation with .
For example, when we want to specify the sotp time of the simulation, it's impossible to set this time equal to 1.5 but only equal to 1 or 2
It's exactly the same thing for the interval

Administrator has disabled public posting. Please login or register in order to proceed.

Re: GUI : unable to use . when configurating the simulation

https://trac.openmodelica.org/OpenModelica/newticket

I assume you use a locale that uses comma instead of dots for the decimal separator? Might be that OMEdit puts some wrong characters in there...

Administrator has disabled public posting. Please login or register in order to proceed.

Re: GUI : unable to use . when configurating the simulation

Is because you might be using different locale. Change your language to English in "Tools->Options->General->Language".
I am guessing your decimal separator is comma instead of dot. However, I found out that OM fails to simulate the class if comma separator is used.

Adeel.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: GUI : unable to use . when configurating the simulation

When i change my Language to english, it works !!
Thanks for your quick answer

Edited by: sebapeti - Feb-17-17 12:01:43
Administrator has disabled public posting. Please login or register in order to proceed.

Re: GUI : unable to use . when configurating the simulation

OMEdit can handle locale aware decimal separator. But using 1,5 fails with OpenModelica API since it is not locale aware.
I will change OMEdit to always send dot as decimal separator to omc.

Adeel.

Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests and 0 other users also viewing this topic
You are here: