OpenModelica


Forgot password? | Forgot username? | Register

Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Hello,
I am new to Openmodelica. I was trying to build from source with a minimal source from git. I have checked and verified the following things,
1) My OMDev is in C:\ and corresponding environment variable is defined
2) In eclipse:
.project fileis referring to the MINGW64 bit builder

I have tried compiling it both from Eclipse and with MSYS, but fails with the following error,

[highlight]java -cp ../3rdParty/antlr/3.2/libantlr3c-3.2/../tool/antlr-3.2.jar org.antlr.Tool -Xconversiontimeout 10000 -report ParModelica_Lexer.g
make[4]: java: Command not found
Makefile.common:111: recipe for target 'ParModelica_Lexer.stamp' failed
make[4]: Leaving directory '/g/OpenModelica-minimal/OMCompiler/Parser'
make[4]: *** [ParModelica_Lexer.stamp] Error 127
make[3]: *** [bootstrap-dependencies] Error 2
Makefile.common:58: recipe for target 'bootstrap-dependencies' failed
make[3]: Leaving directory '/g/OpenModelica-minimal/OMCompiler'
Makefile.omdev.mingw:530: recipe for target 'omc-bootstrapped' failed
make[2]: *** [omc-bootstrapped] Error 2
make[2]: Leaving directory '/g/OpenModelica-minimal/OMCompiler'

real    0m14.281s
user    0m2.905s
sys    0m5.104s
make[1]: *** [omc] Error 2
Makefile.omdev.mingw:332: recipe for target 'omc' failed
make[1]: Leaving directory '/g/OpenModelica-minimal/OMCompiler'
make: *** [omc] Error 2
Makefile.omdev.mingw:37: recipe for target 'omc' failed[/highlight]

Any kind of help will be really appreciated. Thanking you in advance.

Regards
Milan

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

You need to install java and keep java.exe on your PATH

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Hello,

Thank you for the quick reply. I already had Java build version 1.8.0_102 installed. I use "C:\Program Files\Java\jre1.8.0_102\bin" in my path variable and also made sure that the same JRE is used by Eclipse. But still giving the same result.
make[4]: Entering directory '/g/OpenModelica-minimal/OMCompiler/Parser'
java -cp ../3rdParty/antlr/3.2/libantlr3c-3.2/../tool/antlr-3.2.jar org.antlr.Tool -Xconversiontimeout 10000 -report ParModelica_Lexer.g
make[4]: java: Command not found
Makefile.common:111: recipe for target 'ParModelica_Lexer.stamp' failed
make[4]: Leaving directory '/g/OpenModelica-minimal/OMCompiler/Parser'
make[4]: *** [ParModelica_Lexer.stamp] Error 127
Makefile.common:58: recipe for target 'bootstrap-dependencies' failed
make[3]: Leaving directory '/g/OpenModelica-minimal/OMCompiler'
make[3]: *** [bootstrap-dependencies] Error 2
make[2]: *** [omc-bootstrapped] Error 2
Makefile.omdev.mingw:530: recipe for target 'omc-bootstrapped' failed
make[2]: Leaving directory '/g/OpenModelica-minimal/OMCompiler'

real    0m14.385s
user    0m2.773s
sys    0m4.943s
make[1]: *** [omc] Error 2
Makefile.omdev.mingw:332: recipe for target 'omc' failed
make[1]: Leaving directory '/g/OpenModelica-minimal/OMCompiler'
make: *** [omc] Error 2
Makefile.omdev.mingw:37: recipe for target 'omc' failed

For your information, I am using Eclipse Neon  with Windows 7. And in the comilation, it install "KINSOL", and afterwards copying libraries after entering parser, it gives the error.

Thanks and Regards
Milan

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

The path you have in Windows is not used in msys2 or eclipse.

For msys2 you need to give: ming64_shell.bat -use-full-path to use it. See OMDev\INSTALL.txt
You can also use:

Code:


> export PATH=$PATH:/c/path/to/git:/c/Program\ Files/Java/jre1.8.0_102/bin
> make ....

In eclipse, you need to edit the OMDev builder and set the PATH in the Environment tab.

Edited by: adrpo - Aug-17-16 15:17:06
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Hi,

That helped  current/smile . I imported the system path to the Eclipse OMDev Buider environment by adding ${env_var:PATH} to the path in OMDev Builder. It was a bit confusing as the OMDev environment (System variable) is automatically picked up by OMDev Builder in Eclipse and java variables are not.

But now I have the second problem that the libraries are not comping since the its not able to clone from git.

" fatal: unable to access 'https://github.com/OpenModelica/BioChem.git/': error setting certificate verify locations:
  CAfile: C:/Program Files/Git/mingw64/libexec/ssl/certs/ca-bundle.crt
  CApath: none

recipe for target 'BioChem' failed."

I tried to disable this single library, but found that none of the library is comping including the MSL. I am not really able to understand why it is not able to fetch the libraries also why libraries are not cloned from git with openModelica package.

Thanks in advance
Milan

Edited by: milanvk - Aug-18-16 08:40:05
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Hm, I haven't run into these issues before, maybe see here:
http://stackoverflow.com/questions/3778 … repository


You might neeed to configure git or reinstall it. I use git from here:
https://git-scm.com/download/win

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Many thanks, this solved my issues and I succeed in building OMEdit and OMPlot from scratch. I guess the problem was that I installed Git with out administrator rights and certificates were not locked in the installation directory for this reason.

Edited by: milanvk - Aug-18-16 08:41:03
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Hello

I am trying to compile OpenModelica in MSYS, but I'm facing with this error:

fatal: unable to access 'https://openmodelica.org/git/SiemensPower.git/': Received HTTP code 407 from proxy after CONNECT
[ 76%] Built target sundials_idas_static
[ 90%] Built target sundials_kinsol_static
[ 98%] Built target sundials_kinsol_shared
Makefile.libs:612: recipe for target 'SiemensPower' failed
make[2]: *** [SiemensPower] Error 1

however I configured proxy in MSYS, like this:

git config --global http.proxy proxy.server.address:8080.

Do you have any idea how to solve it?

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Hello

Maybe I think you need another command.
I am sorry if I made a mistake, please try the following command in MSYS for proxy setting.

Code:

git config --global http.proxy proxy.server.address:8080

   git config --global https.proxy proxy.server.address:8080

Regards

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Hi,

I did not face this issue as I directly cloned the source from https://github.com/OpenModelica, my credentials was not necessary.
But I guess in your case this can probably help you http://stackoverflow.com/questions/2490 … er-connect
Also please make sure, you are using URL encoded value, if you have any special characters in your password.

Hope this helps

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

I used
git config --global http.proxy http://username:password@proxiURL:proxiPort

and it solved the problem.

Edited by: Fatima - Jun-14-17 11:33:54
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

I face with this error for compiling OpenModelica:

simulation/solver/kinsolSolver.c:62:34: fatal error: kinsol/kinsol_lapack.h: No such file or directory
compilation terminated.
Makefile.common:203: recipe for target 'simulation/solver/kinsolSolver.o' failed
make[2]: *** [simulation/solver/kinsolSolver.o] Error 1

I did rebase my branch with master on OpenModelica, and now all modules seem up to date.

Also I have kinsol_lapack.h file in  OpenModelica\OMCompiler\3rdParty\sundials\include\kinsol but I don't know what is the problem!

Do you have any idea?

Edited by: Fatima - Jun-14-17 11:41:01
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Update your OMDev from SVN.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Build from source fails on Windows + MSYS or Eclipse + MINGW 64bit

Maybe I think you need another command.
I am sorry if I made a mistake, please try the following command in MSYS for proxy setting.

goldenslot

Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests and 0 other users also viewing this topic
You are here: