OpenModelica


Forgot password? | Forgot username? | Register

Simulation info read error - json

Simulation info read error - json

I have a model that builds and compiles OK. But when I run it I get the above error and execution aborts.
from my gdb session (after recompiling with -g flag). 
To me there appears to be some malformed  "<model>_info.json"  file.I need some pointers as to what this error is possibly due to.
I am attaching the "total.mo" file should that be required.

Code:

#2  0x00007ffff7b99b54 in assertNumber (expected=1172, str=<optimized out>) at simulation/simulation_info_json.c:184

#3  readEquation (str=<optimized out>, xml=0xddd1c0, i=i@entry=1172) at simulation/simulation_info_json.c:219
#4  0x00007ffff7b9a6a6 in readEquations (xml=0x7fffffffd440, str=<optimized out>) at simulation/simulation_info_json.c:289
#5  readInfoJson (xml=0x7fffffffd440, str=<optimized out>) at simulation/simulation_info_json.c:360
#6  modelInfoInit (xml=xml@entry=0x7fffffffd440) at simulation/simulation_info_json.c:389
#7  0x00007ffff7b9ad6f in modelInfoGetEquation (xml=0x7fffffffd440, ix=450) at simulation/simulation_info_json.c:407
#8  0x00007ffff7b5bdb3 in getNumericalJacobian (f=0xd86520, x=0xd861f0, jac=0xd86960, dataAndSysNum=0x7fffffff9e80)
    at simulation/solver/nonlinearSolverHybrd.c:234

1450161842_total.mo

Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests and 0 other users also viewing this topic
You are here: