OpenModelica


Forgot password? | Forgot username? | Register

Error regarding flattening of model

Error regarding flattening of model

Hi,
Thanks for giving me a lots of answer before this.
Once again i would like to ask a one simple question to u that during simulation of heating system , i came across error regarding "FLATTENING OF MODEL''.What this error actually mean to say.I have drawn heating system model same as given in the fluid example. Also, i gave the same parameters as given in the example with the same value. Still how, i founded error like flattening of model.i don't know what is error is. I have also founded same error with pumping system also.Can anyone help me to out of this?
Hope for positive reply.
Thanks in advance.
Best ragards,
jitesh

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Error regarding flattening of model

Can you post the model?
Flattening error means we could not translate the model to DAE form (system of equations).
The compiler has 2 phases front-end flattening (removing object orientation and generate the DAE system) and back-end (compiling the DAE system to C code).

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Error regarding flattening of model



Sorry, i don't know how to post model here. but , i have attached screenshot of the model over here. so, please find the attached screenshot and help me out of this error. because, i saw this error in so many examples. And all those my model xamples retain as it is without solving this error.
thanks .
Best regards,
jitesh.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Error regarding flattening of model

What version of OpenModelica are you using? Go to Help->About OMEdit [Connected to OpenModelica ...] Copy the text from there and paste it here.

To post the model you go to the text view (The third icon followed by the (i) icon) and copy the text and paste it here.

Note that you do not need to copy the model by building it from components. You can right click on for example TanksWithOverflow and say "Duplicate".
Then give a name say "MyTanks" and no path. It will be copied at the top level (scroll down in the left side browser) and you can edit whatever you want in it.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Error regarding flattening of model

i have this problem: check is ok but in when i play simulation button there is this error: "[C:/OpenModelica1.9.2/lib/omlibrary/Modelica 3.2.1/Blocks/Math.mo: 1239:5-1240:25]: Model is structurally singular, error found sorting equations 16: batteryStack.cell[1,1].linearDynamicImpedance.cellImpedance.rcseriesLinear.rclinear[1].capacitor.impedanceValue.qabs.abs.y = if noEvent(batteryStack.cell[1,1].linearDynamicImpedance.IBatt_int.i >= 0.0) then batteryStack.cell[1,1].linearDynamicImpedance.IBatt_int.i else -batteryStack.cell[1,1].linearDynamicImpedance.IBatt_int.i; 17: der(batteryStack.cell[1,1].linearDynamicImpedance.cellImpedance.rcseriesLinear.rclinear[1].capacitor.impedanceValue.qabs.absInt.y) = batteryStack.cell[1,1].linearDynamicImpedance.cellImpedance.rcseriesLinear.rclinear[1].capacitor.impedanceValue.qabs.absInt.k * batteryStack.cell[1,1].linearDynamicImpedance.cellImpedance.rcseriesLinear.rclinear[1].capacitor.impedanceValue.qabs.abs.y; 52: batteryStack.cell[1,1].linearDynamicImpedance.cellImpedance.rs.impedanceValue.qabs.abs.y = if noEvent(batteryStack.cell[1,1].linearDynamicImpedance.IBatt_int.i >= 0.0) then batteryStack.cell[1,1].linearDynamicImpedance.IBatt_int.i else -batteryStack.cell[1,1].linearDynamicImpedance.IBatt_int.i; 53: der(batteryStack.cell[1,1]......................................."
what is the problem?

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Error regarding flattening of model

@20088921
From my expirience, I would say there is no fluid defined in your model, or there is some other small dumb error preventing OpenModelica to understand your model.
But I would bet on the missing fluid model. Check your model modifiers in the Text View for "redeclare Package" or something like that.

@claudio34
No idea on that error message. Most likely it would help someone else solving this problem if you provide the model with which this error occurs.

Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests and 0 other users also viewing this topic
You are here: